summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2024-02-13 20:04:10 -0500
committerMarge Bot <emma+marge@anholt.net>2024-02-14 13:08:55 +0000
commit88d0c6c26aa9f00547a8bd2dda36176cb84adfb6 (patch)
tree0605cb46d85e35e1f9928047ba4849da04141f0f /meson.build
parent34078b67ed2fc03bff2c7069d7ec00d72d96461a (diff)
meson: Limit intel_vk_rt to x86_64
Fixes: a512c2a8b57 ("meson: enforce build of intel-clc with anv/iris") Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/10610 Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/27608>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index faadf25a449..c7c507dcca4 100644
--- a/meson.build
+++ b/meson.build
@@ -303,7 +303,8 @@ else
with_intel_clc = false
endif
-with_intel_vk_rt = with_intel_vk and get_option('intel-rt') != 'disabled'
+with_intel_vk_rt = ['x86_64'].contains(host_machine.cpu_family()) and \
+ with_intel_vk and get_option('intel-rt') != 'disabled'
with_any_intel = [
with_gallium_crocus,