summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFaith Ekstrand <faith.ekstrand@collabora.com>2024-02-27 12:36:24 -0600
committerMarge Bot <emma+marge@anholt.net>2024-02-28 19:58:28 +0000
commit75785749efb1e5a1711c868840e3c32e3038fafe (patch)
tree60f83e1382261c2987a70aa0837d232aa2f55b11 /meson.build
parente32c36df079676811f9c02058d6ae384633b5fa1 (diff)
meson: Rename nouveau-experimental to nouveau and build by default on x86
Reviewed-by: Joshua Ashton <joshua@froggi.es> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/27832>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 9471276131c..00be348cab9 100644
--- a/meson.build
+++ b/meson.build
@@ -216,7 +216,7 @@ _vulkan_drivers = get_option('vulkan-drivers')
if _vulkan_drivers.contains('auto')
if system_has_kms_drm
if host_machine.cpu_family().startswith('x86')
- _vulkan_drivers = ['amd', 'intel', 'intel_hasvk', 'swrast']
+ _vulkan_drivers = ['amd', 'intel', 'intel_hasvk', 'nouveau', 'swrast']
elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
_vulkan_drivers = ['swrast', 'intel']
elif ['mips', 'mips64', 'riscv32', 'riscv64'].contains(host_machine.cpu_family())
@@ -239,7 +239,7 @@ elif _vulkan_drivers.contains('all')
_vulkan_drivers = ['amd', 'intel', 'intel_hasvk', 'swrast',
'freedreno', 'panfrost', 'virtio', 'broadcom',
'imagination-experimental', 'microsoft-experimental',
- 'nouveau-experimental']
+ 'nouveau']
endif
with_intel_vk = _vulkan_drivers.contains('intel')
@@ -253,7 +253,7 @@ with_broadcom_vk = _vulkan_drivers.contains('broadcom')
with_imagination_vk = _vulkan_drivers.contains('imagination-experimental')
with_imagination_srv = get_option('imagination-srv')
with_microsoft_vk = _vulkan_drivers.contains('microsoft-experimental')
-with_nouveau_vk = _vulkan_drivers.contains('nouveau-experimental')
+with_nouveau_vk = _vulkan_drivers.contains('nouveau')
with_any_vk = _vulkan_drivers.length() != 0
with_vk_compiler = [