summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@igalia.com>2023-11-20 15:08:26 +0000
committerMarge Bot <emma+marge@anholt.net>2024-04-30 16:22:50 +0000
commit7187373ec2259d2ade1f3a5741f58de6a57c132e (patch)
tree4f7a6f633d94fc9326dcdc12afa5b00c82dc6877 /meson.build
parent21b527632ec23038cde9cbc83ce40bebc15931e5 (diff)
meson: always set USE_LIBGLVND
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/28947>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index e88246f50a3..335b120839d 100644
--- a/meson.build
+++ b/meson.build
@@ -554,9 +554,7 @@ _glvnd = get_option('glvnd') \
error_message: '''EGL lib suffix can't be used with libglvnd''')
dep_glvnd = dependency('libglvnd', version : '>= 1.3.2', required : _glvnd)
with_glvnd = dep_glvnd.found()
-if with_glvnd
- pre_args += '-DUSE_LIBGLVND=1'
-endif
+pre_args += '-DUSE_LIBGLVND=@0@'.format(with_glvnd ? '1' : '0')
glvnd_vendor_name = get_option('glvnd-vendor-name')
if with_vulkan_icd_dir == ''