summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYiwei Zhang <zzyiwei@chromium.org>2024-01-30 16:17:05 -0800
committerMarge Bot <emma+marge@anholt.net>2024-02-01 19:29:49 +0000
commit558aca10b48573ed487292cb4c4ace6085cb5f55 (patch)
treee1ccc50137de170a6541fcdabb97aab639a3b1d3 /meson.build
parent53d9debcf4de881b5b7cd74004c2e698602b4e98 (diff)
meson: drop -DANDROID
Signed-off-by: Yiwei Zhang <zzyiwei@chromium.org> Reviewed-by: Yonggang Luo <luoyonggang@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/27374>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 1d7439d9c63..2bfcb678b89 100644
--- a/meson.build
+++ b/meson.build
@@ -902,10 +902,7 @@ if with_platform_android
dep_android_mapper4 = dependency('android.hardware.graphics.mapper', version : '>= 4.0', required : false)
endif
endif
- pre_args += [
- '-DANDROID',
- '-DANDROID_API_LEVEL=' + get_option('platform-sdk-version').to_string()
- ]
+ pre_args += '-DANDROID_API_LEVEL=' + get_option('platform-sdk-version').to_string()
if get_option('android-strict')
pre_args += '-DANDROID_STRICT'
endif