summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <lionel.g.landwerlin@intel.com>2023-12-20 12:15:43 +0200
committerMarge Bot <emma+marge@anholt.net>2024-02-13 00:06:45 +0000
commit5438b1910464e4b17fe0248a96a6ed98f0280a20 (patch)
treec912d80f7fb202e2e57b50a7806a31168db1495a /meson.build
parentd754ed5330bc94868547ff5b41c8992e8266b4d0 (diff)
iris: enable generated indirect draws
This mirror the ring buffer mode we have in Anv. Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Reviewed-by: Kenneth Graunke <kenneth@whitecape.org> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/26797>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b93077ed837..ade6546b0af 100644
--- a/meson.build
+++ b/meson.build
@@ -299,7 +299,7 @@ if ['x86_64'].contains(host_machine.cpu_family()) and \
get_option('intel-clc') != 'system'
# Require intel-clc with Anv & Iris (for internal shaders)
with_intel_clc = get_option('intel-clc') == 'enabled' or \
- with_intel_vk
+ with_intel_vk or with_gallium_iris
else
with_intel_clc = false
endif