summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYiwei Zhang <zzyiwei@chromium.org>2023-12-21 01:57:50 -0800
committerMarge Bot <emma+marge@anholt.net>2024-01-10 21:06:35 +0000
commit3923d43908fa3ac2c8535e33277229038333fe8f (patch)
tree033774a8b4b9b97942f694e3bea7ed7318bd1fb2 /meson.build
parentfb934751394749982ee854d6ca2cb24f8ce54e27 (diff)
meson/vulkan/util: allow venus to drop compiler deps
Files to compile: 451 => 232 Signed-off-by: Yiwei Zhang <zzyiwei@chromium.org> Reviewed-by: Yonggang Luo <luoyonggang@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/26783>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0c5a03de124..a53d50d036d 100644
--- a/meson.build
+++ b/meson.build
@@ -251,6 +251,20 @@ with_microsoft_vk = _vulkan_drivers.contains('microsoft-experimental')
with_nouveau_vk = _vulkan_drivers.contains('nouveau-experimental')
with_any_vk = _vulkan_drivers.length() != 0
+with_vk_compiler = [
+ with_intel_vk,
+ with_intel_hasvk,
+ with_amd_vk,
+ with_freedreno_vk,
+ with_panfrost_vk,
+ with_swrast_vk,
+ with_broadcom_vk,
+ with_imagination_vk,
+ with_microsoft_vk,
+ with_nouveau_vk,
+].contains(true)
+pre_args += '-DUSE_VK_COMPILER=@0@'.format(with_vk_compiler ? '1' : '0')
+
freedreno_kmds = get_option('freedreno-kmds')
if freedreno_kmds.length() != 0 and freedreno_kmds != [ 'msm' ] and with_freedreno_vk
if freedreno_kmds.contains('msm')