summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLucas Fryzek <lfryzek@igalia.com>2024-04-18 07:36:06 -0400
committerMarge Bot <emma+marge@anholt.net>2024-04-18 22:20:58 +0000
commit112063a060ef2603e66f5ee375346b2d24508c2b (patch)
treea431bfb7899fea59b6cefff15b13aa940fe24a63 /meson.build
parent053b5f3e0cdc3f4e4297dad2ea40090960533c40 (diff)
llvmpipe: Only use udmabuf if header is found
Fixes #11032 Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/28810>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3af6595ea3a..a89a17882c1 100644
--- a/meson.build
+++ b/meson.build
@@ -1373,7 +1373,7 @@ if not ['linux'].contains(host_machine.system())
endif
foreach h : ['xlocale.h', 'linux/futex.h', 'endian.h', 'dlfcn.h', 'sys/shm.h',
- 'cet.h', 'pthread_np.h', 'renderdoc_app.h', 'sys/inotify.h']
+ 'cet.h', 'pthread_np.h', 'renderdoc_app.h', 'sys/inotify.h', 'linux/udmabuf.h']
if cc.check_header(h)
pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
endif