summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <lionel.g.landwerlin@intel.com>2023-11-06 11:10:23 +0200
committerMarge Bot <emma+marge@anholt.net>2024-02-13 00:06:44 +0000
commit012489e55ce3c88615c5fb2667e10e9cfd7b7edb (patch)
tree2db58035c8876a8812aeb607b406dc602428fcea /meson.build
parentc53a4711cb77fdf19b93797106b2ddf846c32d37 (diff)
meson: add a new option to enable intel-clc without building RT shaders
Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Reviewed-by: Kenneth Graunke <kenneth@whitecape.org> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/26797>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 10 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 9153910e8a4..b91d7bf3159 100644
--- a/meson.build
+++ b/meson.build
@@ -295,14 +295,18 @@ with_any_broadcom = [
with_broadcom_vk,
].contains(true)
-if ['x86_64'].contains(host_machine.cpu_family())
+if ['x86_64'].contains(host_machine.cpu_family()) and \
+ get_option('intel-clc') != 'system'
+ # Require intel-clc with Anv & Iris (for internal shaders)
with_intel_clc = get_option('intel-clc') == 'enabled'
- with_intel_vk_rt = with_intel_vk and get_option('intel-clc') != 'disabled'
else
with_intel_clc = false
- with_intel_vk_rt = false
endif
+with_intel_vk_rt = with_intel_vk and \
+ get_option('intel-clc') != 'disabled' and \
+ get_option('intel-rt') != 'disabled'
+
with_any_intel = [
with_gallium_crocus,
with_gallium_i915,
@@ -601,7 +605,7 @@ _vdpau_drivers = [
vdpau = get_option('gallium-vdpau') \
.require(system_has_kms_drm, error_message : 'VDPAU state tracker can only be build on unix-like OSes.') \
.require(with_platform_x11, error_message : 'VDPAU state tracker requires X11 support.') \
- .require(_vdpau_drivers.contains(true), error_message : 'VDPAU state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau, d3d12 (with option gallium-d3d12-video, virgl).')
+ .require(_vdpau_drivers.contains(true), error_message : 'VDPAU state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau, d3d12 (with option gallium-d3d12-video, virgl).')
dep_vdpau = dependency('vdpau', version : '>= 1.1', required : vdpau)
if dep_vdpau.found()
@@ -949,7 +953,7 @@ endif
with_shader_cache = get_option('shader-cache') \
.require(host_machine.system() != 'windows', error_message : 'Shader Cache does not currently work on Windows') \
- .allowed()
+ .allowed()
if with_shader_cache
pre_args += '-DENABLE_SHADER_CACHE'
@@ -1597,7 +1601,7 @@ use_xmlconfig = get_option('xmlconfig') \
.require(dep_expat.found(),
error_message : 'requires expat') \
.allowed()
-
+
# Predefined macros for windows
if host_machine.system() == 'windows'
pre_args += '-DWIN32_LEAN_AND_MEAN' # http://msdn2.microsoft.com/en-us/library/6dwk3a1z.aspx