summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2021-04-22 16:25:07 -0700
committerEmma Anholt <emma@anholt.net>2021-07-30 10:58:11 -0700
commite6fb9ccf2a36b6c64501ff19984ac820473f058f (patch)
tree8c1decd773dbd4fc615740e88355d6a309348dbd /meson.build
parenta819b9ad3b336248c01db8b4e1f184125e0c83da (diff)
meson: Don't build libkms for Android.
Nobody wants that that I know of. Reviewed-by: Kristian H. Kristensen <hoegsberg@google.com> Reviewed-by: Eric Engestrom <eric@engestrom.ch>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 81242000..7ccfe84c 100644
--- a/meson.build
+++ b/meson.build
@@ -173,7 +173,7 @@ endif
with_libkms = false
_libkms = get_option('libkms')
if _libkms != 'false'
- with_libkms = _libkms == 'true' or ['linux', 'freebsd', 'dragonfly'].contains(host_machine.system())
+ with_libkms = _libkms == 'true' or (['linux', 'freebsd', 'dragonfly'].contains(host_machine.system()) and not android)
endif
# Among others FreeBSD does not have a separate dl library.