summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-12-17 23:01:08 +0000
committerDylan Baker <dylan@pnwbakers.com>2022-01-19 16:08:31 -0800
commit63d06ad3c30483577f194d1d1faafc4fe23aeef3 (patch)
treeae3d2fc6d951b9ce542ba9a0dac41384e4006975 /meson.build
parentfa80f49df8c3355c754a908722a422c610b6110a (diff)
use standard `__typeof__()` instead of GNU extension `typeof()`
And switch to c_std=c99. This simplifies using libdrm as a meson subproject for mesa. v2: (dylan) - switch to c99 as the standard - Fix amdgpu security tests as well Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Signed-off-by: Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Simon Ser <contact@emersion.fr> Reviewed-by: Emma Anholt <emma@anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f5704cf1..5b87a227 100644
--- a/meson.build
+++ b/meson.build
@@ -24,7 +24,7 @@ project(
version : '2.4.109',
license : 'MIT',
meson_version : '>= 0.46',
- default_options : ['buildtype=debugoptimized', 'c_std=gnu99'],
+ default_options : ['buildtype=debugoptimized', 'c_std=c99'],
)
pkg = import('pkgconfig')