summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2010-08-23 13:33:55 +0100
committerChristophe Fergeau <cfergeau@mandriva.com>2010-08-23 16:02:05 +0200
commitcb7492942604aa2387b8414c47f673812140fb2d (patch)
treea46c940efafe0128865f7a8b38a6161d7a48a3ba /configure.ac
parent97cdd1c132dc77df65631f630041da1c7d381d0c (diff)
Add parser tools to the distribution
And make the "distcheck" rule actually work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f4b84ff..f6096d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,10 +3,20 @@ AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([media-players/])
PKG_CHECK_MODULES(UDEV, udev)
-AC_SUBST([udev_dir], [$($PKG_CONFIG --variable=udevdir udev)])
+AC_ARG_WITH(udevdir,
+ AS_HELP_STRING([--with-udevdir=DIR],[Installation path for udev rules @<:@auto@:>@]),
+ [ac_with_udevdir=$withval],
+ [ac_with_udevdir=""])
+if test "${ac_with_udevdir}" = ""; then
+ ac_with_udevdir=`$PKG_CONFIG --variable=udevdir udev`
+fi
+
+AC_MSG_NOTICE([installing udev rules in ${ac_with_udevdir}/rules.d])
+AC_SUBST([UDEV_DIR],[${ac_with_udevdir}])
AC_OUTPUT([
Makefile
+tools/Makefile
media-players/Makefile
])