summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2007-10-25 11:46:12 +0200
committerCarlos Garcia Campos <carlosgc@gnome.org>2007-10-25 11:46:12 +0200
commitd5be0148810ab70d58bc678b7aa65730bf4d5e54 (patch)
treec0b575bae314a9b7761334843a3ff8907e13fc19 /configure.ac
Initial importinitial
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a0ae9bb
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,26 @@
+AC_PREREQ(2.59)
+AC_INIT(libspectre, 0.0.1)
+AC_CONFIG_HEADERS(config.h)
+
+AM_INIT_AUTOMAKE([1.7])
+
+AC_PROG_LIBTOOL
+AC_PROG_CC
+AC_ISC_POSIX
+AC_PROG_CC_STDC
+AC_STDC_HEADERS
+
+AC_CHECK_LIB(gs, gsapi_new_instance, have_libgs=yes, have_libgs=no)
+if test "x$have_libgs" = "xyes"; then
+ LIB_GS="-lgs"
+else
+ AC_MSG_ERROR([You need libgs in order to compile libspectre])
+fi
+AC_SUBST(LIB_GS)
+
+AC_OUTPUT([
+Makefile
+libspectre/Makefile
+test/Makefile
+libspectre.pc
+])