summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2019-12-03 15:14:57 +0100
committerAndras Timar <andras.timar@collabora.com>2019-12-06 13:40:09 +0100
commitb83610704bc8ac031112db8336df22380c9390e7 (patch)
tree626c2c1a74b21bb36827e264915a41d4d65e403e /Makefile.am
parenteff3aa96a2fba6471a3873670586b7c991f6d7c0 (diff)
remove bundled LOKit headers
It was a source of confusion that these bundled headers had to be synced with core all the time, and when it did not happen, the builds broke. Change-Id: Id9d0a8a496b293d20c39e855176a00bcb85df640 Reviewed-on: https://gerrit.libreoffice.org/84358 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Andras Timar <andras.timar@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 086ba7613..57a666adb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -230,11 +230,6 @@ kit_headers = kit/ChildSession.hpp \
kit/Watermark.hpp
noinst_HEADERS = $(wsd_headers) $(shared_headers) $(kit_headers) \
- bundled/include/LibreOfficeKit/LibreOfficeKit.h \
- bundled/include/LibreOfficeKit/LibreOfficeKit.hxx \
- bundled/include/LibreOfficeKit/LibreOfficeKitEnums.h \
- bundled/include/LibreOfficeKit/LibreOfficeKitInit.h \
- bundled/include/LibreOfficeKit/LibreOfficeKitTypes.h \
test/WopiTestServer.hpp \
test/countloolkits.hpp \
test/test.hpp \
@@ -242,6 +237,13 @@ noinst_HEADERS = $(wsd_headers) $(shared_headers) $(kit_headers) \
dist-hook:
git log -1 --format=%h > $(distdir)/dist_git_hash 2> /dev/null || rm $(distdir)/dist_git_hash
+ mkdir -p $(distdir)/bundled/include/LibreOfficeKit/
+ cp @LOKIT_PATH@/LibreOfficeKit/LibreOfficeKit.h \
+ @LOKIT_PATH@/LibreOfficeKit/LibreOfficeKit.hxx \
+ @LOKIT_PATH@/LibreOfficeKit/LibreOfficeKitEnums.h \
+ @LOKIT_PATH@/LibreOfficeKit/LibreOfficeKitInit.h \
+ @LOKIT_PATH@/LibreOfficeKit/LibreOfficeKitTypes.h \
+ $(distdir)/bundled/include/LibreOfficeKit/
EXTRA_DIST = discovery.xml \
favicon.ico \