summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.com>2020-04-01 17:22:23 +0200
committerMiklos Vajna <vmiklos@collabora.com>2020-04-02 12:11:24 +0200
commita4e0a00bfe746ccf058dfd46de34bf4fabf5c059 (patch)
tree1e45ead08debeb745da55fbcb627d04ab0b14cd3 /Makefile.am
parent01509b4087904cacc4f71c6758c13a1920334e1f (diff)
Add an initial libfuzzer based fuzzer for the admin console
Run the actual fuzzer like this: ./admin_fuzzer -max_len=16384 fuzzer/admin-data/ Change-Id: I5891df8033ff1837afce86775ee62447587f2f20 Reviewed-on: https://gerrit.libreoffice.org/c/online/+/91504 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e4e6ed5db..3ce60690d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -131,7 +131,9 @@ noinst_PROGRAMS = clientnb \
loolsocketdump
if ENABLE_LIBFUZZER
-noinst_PROGRAMS += clientsession_fuzzer
+noinst_PROGRAMS += \
+ admin_fuzzer \
+ clientsession_fuzzer
else
noinst_PROGRAMS += loolwsd_fuzzer
endif
@@ -161,6 +163,16 @@ loolwsd_fuzzer_SOURCES = $(loolwsd_sources) \
$(shared_sources) \
kit/DummyLibreOfficeKit.cpp
+admin_fuzzer_CPPFLAGS = \
+ -DKIT_IN_PROCESS=1 \
+ $(AM_CPPFLAGS)
+admin_fuzzer_SOURCES = \
+ $(loolwsd_sources) \
+ $(loolforkit_sources) \
+ $(shared_sources) \
+ fuzzer/Admin.cpp
+admin_fuzzer_LDFLAGS = -fsanitize=fuzzer $(AM_LDFLAGS)
+
clientsession_fuzzer_CPPFLAGS = \
-DKIT_IN_PROCESS=1 \
$(AM_CPPFLAGS)