summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHenry Castro <hcastro@collabora.com>2020-03-04 09:09:47 -0400
committerHenry Castro <hcastro@collabora.com>2020-03-05 13:07:25 +0100
commit8a8eb43375d824658013291c8cd8c12a57416b2e (patch)
treecef0a34c31619d8f807f5edd75ef0a884a9063cd /Makefile.am
parent6114b8c8cef37ec517a7b5c8fb47fd144d7ad03a (diff)
wsd: makefile: run server with disabled capabilities
fix runing the server with --disable-setcap, very useful to debug when attaching kit process Change-Id: I5ded5a1aa1924a9325ae76be46b32c0020d8ce35 WARNING: This is just for development and debugging purposes Reviewed-on: https://gerrit.libreoffice.org/c/online/+/89970 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Henry Castro <hcastro@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bf5725b92..f183ad6ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -302,6 +302,7 @@ EXTRA_DIST = discovery.xml \
if HAVE_LO_PATH
SYSTEM_STAMP = @SYSTEMPLATE_PATH@/system_stamp
+CAPABILITIES = $(if @ENABLE_SETCAP@,true,false)
$(SYSTEM_STAMP) : ${top_srcdir}/loolwsd-systemplate-setup
if test "z@SYSTEMPLATE_PATH@" != "z"; then rm -rf "@SYSTEMPLATE_PATH@"; fi
@@ -322,6 +323,7 @@ run: all @JAILS_PATH@
@cp $(abs_top_srcdir)/test/data/hello.odp $(abs_top_srcdir)/test/data/hello-world.odp
@echo
./loolwsd --o:sys_template_path="@SYSTEMPLATE_PATH@" \
+ --o:security.capabilities="$(CAPABILITIES)" \
--o:child_root_path="@JAILS_PATH@" --o:storage.filesystem[@allow]=true \
--o:ssl.cert_file_path="$(abs_top_srcdir)/etc/cert.pem" \
--o:ssl.key_file_path="$(abs_top_srcdir)/etc/key.pem" \