summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHenry Castro <hcastro@collabora.com>2020-03-04 15:38:17 -0400
committerHenry Castro <hcastro@collabora.com>2020-03-06 13:37:53 +0100
commit7ba4e9dd2324534c729b053afcf7062f58ebed9a (patch)
tree56156315e647faecea91955b5920943a0c8cb06e /Makefile.am
parent9d412a164e3931b154b0c6d348bb4576609d882a (diff)
wsd: debug: run the server with a single "lokit" process
Sometimes it is very useful to have one "lokit" process, to focus on a 100% reproducible bug, and not worry that server pre-spawn several processes. Change-Id: I414a8145b53a0601a282cba9c245833f5d07f404 Reviewed-on: https://gerrit.libreoffice.org/c/online/+/89999 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Henry Castro <hcastro@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f183ad6ff..9d04569b2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -331,6 +331,25 @@ run: all @JAILS_PATH@
--o:admin_console.username=admin --o:admin_console.password=admin \
--o:logging.file[@enable]=true --o:logging.level=trace
+if ENABLE_DEBUG
+run-one: all @JAILS_PATH@
+ @echo "Launching loolwsd"
+ @fc-cache "@LO_PATH@"/share/fonts/truetype
+ @cp $(abs_top_srcdir)/test/data/hello.odt $(abs_top_srcdir)/test/data/hello-world.odt
+ @cp $(abs_top_srcdir)/test/data/hello.ods $(abs_top_srcdir)/test/data/hello-world.ods
+ @cp $(abs_top_srcdir)/test/data/hello.odp $(abs_top_srcdir)/test/data/hello-world.odp
+ @echo
+ ./loolwsd --o:sys_template_path="@SYSTEMPLATE_PATH@" \
+ --o:security.capabilities="$(CAPABILITIES)" \
+ --o:child_root_path="@JAILS_PATH@" --o:storage.filesystem[@allow]=true \
+ --o:ssl.cert_file_path="$(abs_top_srcdir)/etc/cert.pem" \
+ --o:ssl.key_file_path="$(abs_top_srcdir)/etc/key.pem" \
+ --o:ssl.ca_file_path="$(abs_top_srcdir)/etc/ca-chain.cert.pem" \
+ --o:admin_console.username=admin --o:admin_console.password=admin \
+ --o:logging.file[@enable]=true --o:logging.level=trace \
+ --singlekit
+endif
+
sync-writer:
browser-sync start --config browsersync-config.js --startPath "loleaflet/96c23f663/loleaflet.html?file_path=file://$(abs_top_srcdir)/test/data/hello-world.odt"