summaryrefslogtreecommitdiff
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
new file mode 100644
index 0000000..fa87a13
--- /dev/null
+++ b/src/test/Makefile.am
@@ -0,0 +1,27 @@
+## -*- Mode: make; tab-width: 4; indent-tabs-mode: tabs -*-
+
+target_test = test
+
+check_PROGRAMS = $(target_test)
+
+AM_CXXFLAGS = \
+ -I$(top_srcdir)/inc \
+ -I$(top_srcdir)/src/lib \
+ $(CPPUNIT_CFLAGS) \
+ $(REVENGE_CFLAGS) \
+ $(DEBUG_CXXFLAGS)
+
+test_LDFLAGS = -L$(top_srcdir)/src/lib
+test_LDADD = \
+ $(top_builddir)/src/lib/libfreehand-internal.la \
+ $(CPPUNIT_LIBS) \
+ $(REVENGE_LIBS) \
+ $(ZLIB_LIBS)
+
+test_SOURCES = \
+ FHInternalStreamTest.cpp \
+ test.cpp
+
+TESTS = $(target_test)
+
+## vim:set shiftwidth=4 tabstop=4 noexpandtab: