summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFridrich Štrba <fridrich.strba@bluewin.ch>2015-12-20 14:57:45 +0100
committerFridrich Štrba <fridrich.strba@bluewin.ch>2015-12-20 14:59:05 +0100
commit22b405018fa4d883babb6e510b8dd58ddb55650d (patch)
tree7093341c79a38d072b6ea44868bddafe5de6650b /configure.ac
parenta703628e3c813c85b3b55fce49d666e5f1b25b1f (diff)
Better way to get the gperf dependencies
Change-Id: Ic94d9277949ec84c5f1c0796842507f7b03e6c0f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 2 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index feb11fc..09ff095 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,18 +41,8 @@ AC_PROG_SED
dnl ===================================================================
dnl Check for gperf
dnl ===================================================================
-AC_ARG_VAR(GPERF, [Setting this variable will override the gperf detection])
-AC_PATH_PROG(GPERF, gperf)
-if test -z "$GPERF"; then
- AC_MSG_ERROR([gperf not found but needed. Install it.])
-fi
-AC_MSG_CHECKING([gperf version])
-if test "`$GPERF --version | $EGREP ^GNU\ gperf | $AWK '{ print $3 }' | cut -d. -f1`" -ge "3"; then
- AC_MSG_RESULT([OK])
-else
- AC_MSG_ERROR([too old, you need at least 3.0.0])
-fi
-AC_SUBST(GPERF)
+AM_MISSING_PROG([GPERF], [gperf])
+AM_MISSING_PROG([PERL], [perl])
# ===============
# Find librevenge