summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2017-04-07 13:41:33 +0200
committerDavid Tardon <dtardon@redhat.com>2017-04-07 13:45:51 +0200
commit47d8cb5bc7cf151417dcd93604d091cb7c532c27 (patch)
treec266fd3bbbc616dcf1289335be976c458e40de65 /configure.ac
parent4da35d628e149cfda5dbef16775dd5fd99537eb8 (diff)
allow to build without liblangtag
This is only a hack for simplifying build for oss-fuzz and it should not be used for "real" builds. Change-Id: I33f8ab02d77b1dee198fab2d811fb3939433c6c4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f3ddfdb..6849052 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,9 +80,19 @@ AC_SUBST(ZLIB_LIBS)
# ===============
# Find liblangtag
# ===============
-PKG_CHECK_MODULES([LANGTAG],[
- liblangtag
-])
+AC_ARG_WITH([liblangtag],
+ [AS_HELP_STRING([--without-liblangtag], [Disable use of liblangtag])],
+ [with_liblangtag="$withval"],
+ [with_liblangtag="yes"]
+)
+AS_IF([test "x$with_liblangtag" = "xyes"], [
+ PKG_CHECK_MODULES([LANGTAG],[
+ liblangtag
+ ])
+ AC_DEFINE([WITH_LIBLANGTAG], [1], [Build with liblangtag])
+ ],
+ []
+)
# ==================
# Find boost headers
@@ -439,6 +449,7 @@ Build configuration:
debug: ${enable_debug}
docs: ${build_docs}
fuzzers: ${enable_fuzzers}
+ liblangtag: ${with_liblangtag}
tests: ${enable_tests}
tools: ${build_tools}
werror: ${enable_werror}