summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFridrich Štrba <fridrich.strba@bluewin.ch>2013-11-29 09:40:55 +0100
committerFridrich Štrba <fridrich.strba@bluewin.ch>2013-11-29 09:40:55 +0100
commit6bbd6b3193cf106a4b1edbbde9b5dc577d2f70d4 (patch)
treeecac0182c4f8a147a939ed384a448c660414297f /configure.ac
parentcd3a9bf16d69cf074df578b0e3824dca5351aee1 (diff)
Token map vor AWML tokens
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 97d1e43..ac15f4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -201,6 +201,22 @@ AS_IF([test "x$with_docs" != "xno"], [
AM_CONDITIONAL([WITH_LIBABW_DOCS], [test "x$build_docs" != "xno"])
+dnl ===================================================================
+dnl Check for gperf
+dnl ===================================================================
+AC_ARG_VAR(GPERF, [Setting this variable will override the gperf detection])
+AC_PATH_PROG(GPERF, gperf)
+if test -z "$GPERF"; then
+ AC_MSG_ERROR([gperf not found but needed. Install it.])
+fi
+AC_MSG_CHECKING([gperf version])
+if test "`$GPERF --version | $EGREP ^GNU\ gperf | $AWK '{ print $3 }' | cut -d. -f1`" -ge "3"; then
+ AC_MSG_RESULT([OK])
+else
+ AC_MSG_ERROR([too old, you need at least 3.0.0])
+fi
+AC_SUBST(GPERF)
+
# ===============
# Find librevenge
# ===============