summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHubert Figuière <hub@figuiere.net>2023-02-20 23:30:56 -0500
committerHubert Figuière <hub@figuiere.net>2023-02-20 23:32:06 -0500
commit76ea61c1c3785dd236a0d4cdf961b8b6918aa5b2 (patch)
tree9ef59becd90f449ad8b23cc561db6eb2d80dccdc /Cargo.toml
parentbf6db6b324d73d581caf97f0fde917bba1c5d84e (diff)
rust: use thiserror for errors
- use matches! in test for error matching (not PartialEq)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c1a3f83..3525673 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,6 +19,7 @@ num_enum = "0.5.9"
once_cell = "1.12.0"
rayon = "1.6.1"
simple_logger = { version = "2.1.0", default-features = false }
+thiserror = "1.0.38"
[dev-dependencies]
crc = "2.1.0"