summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHubert Figuière <hub@figuiere.net>2022-03-29 21:21:52 -0400
committerHubert Figuière <hub@figuiere.net>2022-03-29 21:21:52 -0400
commit4c8a3c3ce34c9245cfd489f775468e223d713c57 (patch)
tree1738f0fcd3d046df6cdc2dfcb087d2881e3d2b6d /Cargo.toml
parent70e4f49497e69b21f02f72d2ac7f6f9c35a50319 (diff)
rust: Build with Rust edition 2018
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6925250..10d2f32 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "libopenraw"
version = "0.4.0"
-edition = "2021"
+edition = "2018"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
@@ -13,7 +13,7 @@ lazy_static = "1.4.0"
log = "0.4.14"
mp4parse = { path = "lib/mp4/mp4parse", version = "0.11.4", features = [ "craw" ] }
once_cell = "1.9.0"
-simple_logger = "2.1.0"
+simple_logger = { version = "2.1.0", default-features = false }
[dev-dependencies]
crc = "2.1.0"