summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-11-02 04:38:44 +0000
committerDavid Schleef <ds@schleef.org>2004-11-02 04:38:44 +0000
commit423817bbd7fb6b9497d2deda297dbf054e6a5264 (patch)
treee301a478923fedd884ad146dad796e7490c4b77f /Makefile.am
parenta539445a11f802155a9a106065c6011707c3c507 (diff)
* COPYING: add
* Makefile.am: Add COPYING, fix CLEANFILES * configure.ac: version bump * examples/jpeg/Makefile.am: fix glib dep * liboil/Makefile.am: add md5, fix glib dep * liboil/copy/Makefile.am: * liboil/liboilfuncs.h: update * liboil/liboilfunction.c: (oil_class_choose_by_name): add new function * liboil/liboilfunction.h: same * liboil/md5/Makefile.am: add md5 function class * liboil/md5/md5.c: (md5_c): * liboil/md5/md5.h: * liboil/md5/md5_i386.c: (md5_asm1), (md5_asm2): * testsuite/Makefile.am: add an md5 test * testsuite/md5.c: (test), (main):
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c9df40a..c30ff1c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,11 @@
SUBDIRS = liboil testsuite examples
+EXTRA_DIST = COPYING
+
pkgconfig_DATA = liboil-$(LIBOIL_MAJORMINOR).pc
liboil-$(LIBOIL_MAJORMINOR).pc: liboil.pc
cp liboil.pc liboil-$(LIBOIL_MAJORMINOR).pc
+
+CLEANFILES = liboil-$(LIBOIL_MAJORMINOR).pc