summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-12-14 13:47:32 +0000
committerOlivier Crête <olivier.crete@collabora.com>2018-12-14 14:47:01 -0500
commit6f5e279187d1b07620a16e1c789dd88cb306497a (patch)
tree3cdf55dc82aae04b10a7696ad659d62fa705d667 /meson.build
parent94a7d8eb3d9eec65be5af49acd65329836fbf224 (diff)
stun: tools: drop getopt for arg parsing for better windows compatibility
Just implement argument parsing ourselves here. It's not really more lines of code than the getopt.h variant and makes things build on Windows with MSVC without having to ship a separate getopt implementation.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d27d396..4194df9 100644
--- a/meson.build
+++ b/meson.build
@@ -81,7 +81,7 @@ cdata.set('NICEAPI_EXPORT', true,
description: 'Public library function implementation')
# headers
-foreach h : ['arpa/inet.h', 'net/in.h', 'netdb.h', 'ifaddrs.h']
+foreach h : ['arpa/inet.h', 'net/in.h', 'netdb.h', 'ifaddrs.h', 'unistd.h']
if cc.has_header(h)
define = 'HAVE_' + h.underscorify().to_upper()
cdata.set(define, 1)