summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-02-24 09:37:36 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2020-02-24 11:52:14 +1000
commit15e0b024dfc78da98721e3d82c445cbdf59159e2 (patch)
tree35c1366b6646334f918f4f22ba4230a5ab61d191 /meson.build
parente03cdd1d3ff3731eb1432501c48b742e2c6e34ca (diff)
gitlab CI: hook up junit test reports to the meson results
The KVM tests use this for now, not the container builds where we run meson directly. The python script to convert meson test logs to junit results expects suite names, so let's add all tests to suites so we don't need to carry local modifications. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 7 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index e6c43db..18e4d2e 100644
--- a/meson.build
+++ b/meson.build
@@ -147,7 +147,7 @@ if dep_check.found()
],
dependencies: [dep_libevdev, dep_check],
install: false)
- test('test-event-codes', test_event_codes)
+ test('test-event-codes', test_event_codes, suite: 'library')
test_internals = executable('test-internals',
sources: src_common + [
@@ -155,7 +155,7 @@ if dep_check.found()
],
dependencies: [dep_libevdev, dep_check],
install: false)
- test('test-internals', test_internals)
+ test('test-internals', test_internals, suite: 'library')
test_uinput = executable('test-uinput',
sources: src_common + [
@@ -163,7 +163,7 @@ if dep_check.found()
],
dependencies: [dep_libevdev, dep_check],
install: false)
- test('test-uinput', test_uinput)
+ test('test-uinput', test_uinput, suite: 'library')
test_libevdev = executable('test-libevdev',
sources: src_common + [
@@ -173,7 +173,7 @@ if dep_check.found()
],
dependencies: [dep_libevdev, dep_check],
install: false)
- test('test-libevdev', test_libevdev)
+ test('test-libevdev', test_libevdev, suite: 'library')
test_kernel = executable('test-kernel',
sources: src_common + [
@@ -181,7 +181,7 @@ if dep_check.found()
],
dependencies: [dep_libevdev, dep_check],
install: false)
- test('test-kernel', test_kernel)
+ test('test-kernel', test_kernel, suite: 'kernel')
valgrind = find_program('valgrind', required: false)
@@ -205,7 +205,8 @@ if dep_check.found()
test_static_link = find_program('test/test-static-symbols-leak.sh')
test('static-symbols-leak', test_static_link,
- args: [meson.current_build_dir()])
+ args: [meson.current_build_dir()],
+ suite: 'static')
endif
doxygen = find_program('doxygen', required: get_option('documentation'))