summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2016-11-30 10:13:22 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2016-11-30 20:34:46 +1000
commitb261868b0a14346ed85db38038b6648890fe4f2f (patch)
tree263ce7d1164f240ec9d2d2e7351e00d1253c1b37 /configure.ac
parente938e0b959380bae0007a6e9612b0a1fa3ed06c9 (diff)
Disable test runs on make distcheck
The tests all need root, but running distcheck as root is not ideal. Disable the test runs (but not the build) to make it easier to verify distcheck works as intended. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Benjamin Tissoires <benjamin.tissoires@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ee68614..4763ee1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,11 @@ AM_CONDITIONAL(HAVE_VALGRIND, [test "x$VALGRIND" != "x"])
AM_CONDITIONAL(ENABLE_RUNTIME_TESTS, [test "x$HAVE_CHECK" = "xyes"])
AM_CONDITIONAL(ENABLE_STATIC_LINK_TEST, [test "x$enable_static" = "xyes"])
+AC_ARG_ENABLE([test-run],
+ AS_HELP_STRING([--enable-test-run], [For internal use only]),
+ [run_tests="$enableval"], [run_tests="yes"])
+AM_CONDITIONAL(RUN_TESTS, [test "x$run_tests" = "xyes"])
+
with_cflags=""
if test "x$GCC" = "xyes"; then
CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
@@ -163,6 +168,7 @@ AC_MSG_RESULT([
Build documentation ${have_doxygen}
Enable unit-tests ${HAVE_CHECK}
+ Run unit-tests ${run_tests}
Enable profiling ${enable_gcov}
Static library symbol check ${static_symbol_leaks_test}
])