summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7be1a49..01ac67b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,21 +2,23 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ([2.63])
-AC_INIT([libdlo], [1.0.0], [libdlo@displaylink.com])
+AC_INIT([libdlo], [0.1.0], [libdlo@displaylink.com])
+AC_CONFIG_AUX_DIR([config])
AM_INIT_AUTOMAKE([-Wall -Werror foreign dist-bzip2])
AC_CONFIG_SRCDIR([src/dlo_grfx.c])
AC_USE_SYSTEM_EXTENSIONS
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS([config.h])
-AC_PROG_LIBTOOL
# Checks for programs.
AC_PROG_CC
+AC_PROG_LIBTOOL
-# Checks for libraries.
+# create LIBTOOLS macros.
+LT_INIT
# Checks for header files.
-AC_CHECK_HEADERS([stdint.h stdlib.h string.h])
+AC_CHECK_HEADERS([stdint.h stdlib.h string.h usb.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL
@@ -29,6 +31,7 @@ AC_TYPE_UINT64_T
AC_TYPE_UINT8_T
# Checks for library functions.
+PKG_CHECK_MODULES(LIBUSB, libusb >= 0.1.12)
AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_CHECK_FUNCS([gettimeofday strchr])
@@ -37,7 +40,7 @@ AC_CONFIG_FILES([Makefile
src/Makefile
test/Makefile
test/test1/Makefile
- test/test1/src/Makefile])
+ ])
AC_OUTPUT
AC_MSG_RESULT([
libdlo $VERSION