summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordobey <dobey>2006-08-18 20:27:57 +0000
committerdobey <dobey>2006-08-18 20:27:57 +0000
commitffc7c751a76448614fa6cb608a648f77a761d9d0 (patch)
treec8e013c81c955bd5c1d5d6d3462f9e549745e4bd /configure.ac
parentcdb3a4ba8c64a089dbba65603299df01a0b08d92 (diff)
2006-08-18 Rodney Dawes <dobey@novell.com>
* configure.ac: Determine the python site-packages path and substitute it for the Makefiles to use * find-python-path.py: Add this script to discover the python path * python/Makefile.am: Remove the pythondir declaration from here, as it is now defined by the configure script
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2e72c2b..86dbc04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,12 @@ AC_COPYRIGHT([Copyright 2006 Novell, Inc.])
AM_INIT_AUTOMAKE
AM_MAINTAINER_MODE
+AC_MSG_CHECKING([python site path])
+pythonsitedir="`./find-python-path.py`"
+pythondir="\${libdir}/${pythonsitedir}"
+AC_MSG_RESULT([$pythondir])
+AC_SUBST(pythondir)
+
AC_CONFIG_FILES([
Makefile
python/Makefile
@@ -15,4 +21,3 @@ scripts/Makefile
])
AC_OUTPUT
-