summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Hausmann <shausman@rhea.troll.no>2007-02-16 11:06:54 +0100
committerSimon Hausmann <shausman@rhea.troll.no>2007-03-28 12:52:27 +0200
commit1dd5ff781c0d653f57daedbfc766a932477d7b47 (patch)
treeff6d342887b4d7f1530371d223dbfcc4fb500fd9 /configure.ac
parentc700d406380fe55a9d4f42f091ec0feed11e60c2 (diff)
Enable warnings for gcc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a16b38..d2759cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,11 @@ AM_PROG_LIBTOOL
PKG_PROG_PKG_CONFIG
AM_CONFIG_HEADER(config.h)
+if test "x$ac_compiler_gnu" = xyes; then
+ CFLAGS="$CFLAGS -Wall -W"
+ CXXFLAGS="$CXXFLAGS -Wall -W"
+fi
+
AC_PATH_PROG(ft_config,freetype-config,no)
if test "$ft_config" = "no"; then
AC_MSG_ERROR([You must have freetype installed; see http://www.freetype.org/])