summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2020-06-22 21:02:52 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2020-06-22 21:05:26 +0530
commitdd4a2d08485abbaad05a3e64a9a6034f9f788d04 (patch)
treea6661342c23b40aabd6c3e023fc70ed1f75536db /setup.py
parent586abb8abbe5cb5de2b36f8a547f038667413104 (diff)
cerbero: Fix bundle-source and recipe missing files1.17.1
They were using shell.check_call which was removed a few months ago. Part-of: <https://gitlab.freedesktop.org/gstreamer/cerbero/-/merge_requests/523>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b8d47b22..4efe5ec5 100644
--- a/setup.py
+++ b/setup.py
@@ -18,10 +18,10 @@ def read(fname):
# Utility function to parse directories
def parse_dir(dirpath, extension=None):
if os.path.exists('.git'):
- files = shell.check_call('git ls-files %s' % dirpath).split('\n')
+ files = shell.check_output(['git', 'ls-files', dirpath]).split('\n')
files.remove('')
else:
- files = shell.check_call('find %s -type f' % dirpath).split('\n')
+ files = shell.check_output(['find', dirpath, '-type', 'f']).split('\n')
files.remove('')
if extension is None:
return files