summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorL. E. Segovia <amy@centricular.com>2023-12-07 18:06:00 -0300
committerL. E. Segovia <amy@centricular.com>2023-12-26 11:33:59 -0300
commita6908259069df08fd71650b0b3bf019ee818f193 (patch)
treec0191aded0dad48090891993da026f5500f00e09 /meson.build
parentbd7851494c33d9f79cd610a91d889b5e74dfb116 (diff)
orc: Add support for AVX
Fixes #13 Part-of: <https://gitlab.freedesktop.org/gstreamer/orc/-/merge_requests/111>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b36f274..76dd11d 100644
--- a/meson.build
+++ b/meson.build
@@ -41,7 +41,7 @@ if cc.has_argument('-fvisibility=hidden')
add_project_arguments('-fvisibility=hidden', language: 'c')
endif
-all_backends = ['sse', 'mmx']
+all_backends = ['avx', 'sse', 'mmx']
extra_backends = ['altivec', 'neon', 'mips', 'c64x'] # 'arm'
enabled_backends = []
@@ -216,6 +216,7 @@ configure_file(output : 'config.h', configuration : cdata)
# summary
summary({
+ 'AVX': 'avx' in enabled_backends,
'SSE': 'sse' in enabled_backends,
'MMX': 'mmx' in enabled_backends,
'NEON': 'neon' in enabled_backends,