summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <jan@centricular.com>2014-04-30 23:23:42 +1000
committerJan Schmidt <jan@centricular.com>2014-04-30 23:23:42 +1000
commit328916036e5faf44fe641a008cf72070b72e9998 (patch)
tree13e3cb7a1a43d30613c71bcd9b3fbdb242129217 /configure.ac
parent62acbd16cb0e0f5e1848352bec7bb8a7980f71cb (diff)
Fix RTSP server support.
The pkg-config file for RTSP server was renamed in 2012, so I guess noone has built RTSP support since then. Fix the build for the GstRTSPMediaMapping -> GstRTSPMountPoints renaming that happened a while back too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3657d75..95ecfe3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,9 +190,9 @@ AG_GST_PKG_CHECK_MODULES(GST,
AG_GST_PKG_CHECK_MODULES(GST_CHECK, gstreamer-check-$GST_API_VERSION, yes)
AM_CONDITIONAL(HAVE_GST_CHECK, test "x$HAVE_GST_CHECK" = "xyes")
-GST_RTSP_SERVER_REQ=0.10.1
+GST_RTSP_SERVER_REQ=1.0.0
AG_GST_PKG_CHECK_MODULES(GST_RTSP_SERVER,
- gst-rtsp-server-$GST_API_VERSION >= $GST_RTSP_SERVER_REQ)
+ gstreamer-rtsp-server-$GST_API_VERSION >= $GST_RTSP_SERVER_REQ)
if test "$HAVE_GST_RTSP_SERVER" = yes ; then
AC_DEFINE(ENABLE_RTSP, 1, [Enable RTSP])
fi