summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2018-09-21 22:31:33 +0900
committerTim-Philipp Müller <tim@centricular.com>2018-09-21 18:39:02 +0100
commitcfc8d7ec9e37cf766e787a93af5bb4a6ea5b49fa (patch)
tree40b6ead421caabcf1261a964500ecd3d5594ed93 /meson.build
parentcde4cfe38461940c5ce853257e979e01c538156f (diff)
meson: Specify encoding to UTF-8 when building with MSVC
Fix build on some non-US locale Windows systems Error: gst-plugins-base/tools/gst-device-monitor.c(278): error C2001 https://bugzilla.gnome.org/show_bug.cgi?id=797186
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 37013dee0..6f940b821 100644
--- a/meson.build
+++ b/meson.build
@@ -46,6 +46,7 @@ if cc.get_id() == 'msvc'
'/wd4146', # unary minus on unsigned (beware INT_MIN)
'/wd4244', # lossy type conversion (e.g. double -> int)
'/wd4305', # truncating type conversion (e.g. double -> float)
+ cc.get_supported_arguments(['/utf-8']), # set the input encoding to utf-8
language : 'c')
# Disable SAFESEH with MSVC for plugins and libs that use external deps that
# are built with MinGW