summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2021-05-17 00:33:44 +0100
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2021-05-17 14:49:38 +0000
commit57578529a0d017f945f5f0ed90fcc2d60580622a (patch)
tree95943d7b4f2ff406a6333833b7284c81ea04d300 /meson.build
parent5bc1a632e452784cb206a9532f6d3455e605e98a (diff)
meson: fix up wrong escaping of variables in gl and plugins-base .pc file
Workaround for pkg.generate() escaping spaces in pc variables that shouldn't be escaped. Perhaps going back to configure_file() would be a better option though. Really needs a fix in Meson. Fixes https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/issues/884 Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/merge_requests/1150>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index db64239d7..597737725 100644
--- a/meson.build
+++ b/meson.build
@@ -447,6 +447,8 @@ pkgconfig_variables = ['exec_prefix=${prefix}',
'libexecdir=${prefix}/libexec']
pkgconfig_subdirs = ['gstreamer-1.0']
+meson_pkg_config_file_fixup_script = find_program('scripts/meson-pkg-config-file-fixup.py')
+
python3 = import('python').find_installation()
subdir('gst-libs')
subdir('gst')
@@ -483,6 +485,11 @@ pkgconfig.generate(
description : 'Streaming media framework, base plugins libraries',
)
+# Desperate times, desperate measures... fix up escaping of our variables
+run_command(meson_pkg_config_file_fixup_script,
+ 'gstreamer-plugins-base-1.0', 'libraries',
+ check: true)
+
if have_orcc
update_orc_dist_files = find_program('scripts/update-orc-dist-files.py')