summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2019-03-23 18:47:57 +0000
committerTim-Philipp Müller <tim@centricular.com>2019-03-23 19:18:39 +0000
commit4413f44449f85c4933e7952aa2bd959aab07a77c (patch)
treee627d0a7f9216e8ad01929deb1a8dcabf498e4b8 /meson.build
parent2ad6b0b432dff4b45e8731598e56fedd574f63b6 (diff)
g-i: pass --quiet to g-ir-scanner
This suppresses the annoying 'g-ir-scanner: link: cc ..' output that we get even if everything works just fine. We still get g-ir-scanner warnings and compiler warnings if we pass this option.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index bbb2f4c38..3a5cc361b 100644
--- a/meson.build
+++ b/meson.build
@@ -362,7 +362,7 @@ gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' +
'g_setenv("GST_REGISTRY_1.0", "@0@", TRUE);'.format(meson.current_build_dir() + '/gir_empty_registry.reg') + \
'g_setenv("GST_PLUGIN_PATH_1_0", "", TRUE);' + \
'g_setenv("GST_PLUGIN_SYSTEM_PATH_1_0", "", TRUE);' + \
- 'gst_init(NULL,NULL);' ]
+ 'gst_init(NULL,NULL);', '--quiet']
pkgconfig = import('pkgconfig')
plugins_pkgconfig_install_dir = join_paths(plugins_install_dir, 'pkgconfig')