summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDoug Nazar <nazard@nazar.ca>2019-09-02 16:20:07 -0400
committerSebastian Dröge <slomo@coaxion.net>2019-09-03 06:24:26 +0000
commit32395fe83771f5a581811dd42cbc106529e13132 (patch)
tree7bc86118b2f76b7a921c5e91a775e3520332c1a3 /meson.build
parent0c955c16ce52b42b52b6e594f97c5ae73db41c47 (diff)
meson: Reenable NEON support
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f63b72130..264d84c9e 100644
--- a/meson.build
+++ b/meson.build
@@ -334,6 +334,18 @@ have_sse = cc.has_argument(sse_args)
have_sse2 = cc.has_argument(sse2_args)
have_sse41 = cc.has_argument(sse41_args)
+if host_machine.cpu_family() == 'arm'
+ if cc.compiles('''
+#include <arm_neon.h>
+int32x4_t testfunc(int16_t *a, int16_t *b) {
+ asm volatile ("vmull.s16 q0, d0, d0" : : : "q0");
+ return vmull_s16(vld1_s16(a), vld1_s16(b));
+}
+''', name : 'NEON support')
+ core_conf.set('HAVE_ARM_NEON', true)
+ endif
+endif
+
if gst_dep.type_name() == 'internal'
gst_proj = subproject('gstreamer')