summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@igalia.com>2018-10-22 08:17:24 +0200
committerThibault Saunier <tsaunier@igalia.com>2019-05-13 11:34:08 -0400
commit27ba8d24ec00c3be458e6acf7c27547ea08ebee6 (patch)
treea21c692f66b6b4af119074486ab2c58e984d6522 /meson.build
parentcf6ed5700c85dd1b4cf61b5a92ec4ff0bc02238d (diff)
doc: Port to hotdoc
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 4 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index d5a05d01e..1a6bdd66c 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gst-plugins-base', 'c',
version : '1.17.0.1',
- meson_version : '>= 0.47',
+ meson_version : '>= 0.48',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])
@@ -32,6 +32,7 @@ libversion = '@0@.@1@.0'.format(soversion, curversion)
osxversion = curversion + 1
plugins_install_dir = join_paths(get_option('libdir'), 'gstreamer-1.0')
+plugins = []
cc = meson.get_compiler('c')
host_system = host_machine.system()
@@ -371,6 +372,7 @@ if get_option('default_library') == 'shared'
plugins_pkgconfig_install_dir = disabler()
endif
+python3 = import('python').find_installation()
subdir('gst-libs')
subdir('gst')
subdir('ext')
@@ -380,25 +382,14 @@ if not get_option('tools').disabled()
endif
subdir('tests')
subdir('pkgconfig')
-
# xgettext is optional (on Windows for instance)
if find_program('xgettext', required : get_option('nls')).found()
core_conf.set('ENABLE_NLS', 1)
subdir('po')
endif
-
-if build_machine.system() == 'windows'
- message('Disabling gtk-doc while building on Windows')
-else
- if find_program('gtkdoc-scan', required : get_option('gtk_doc')).found()
- subdir('docs')
- else
- message('Not building documentation as gtk-doc was not found')
- endif
-endif
+subdir('docs')
# Use core_conf after all subdirs have set values
configure_file(output : 'config.h', configuration : core_conf)
-python3 = import('python').find_installation()
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')