summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2017-10-16 14:47:07 +0200
committerSebastian Dröge <sebastian@centricular.com>2017-10-19 16:44:06 +0200
commit4f91b6f8739adbf96e9f9129603e2cedde99d43a (patch)
treec985f9b6464e0397f4331e930f4327fe28080c05 /meson.build
parentb3d63d613a64227390cee7aff921872e6b475b6c (diff)
add test support
Most of the boilerplate and the states test has been copied from gst-plugins-good. https://bugzilla.gnome.org/show_bug.cgi?id=789094
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6917826..12f3ec1 100644
--- a/meson.build
+++ b/meson.build
@@ -153,6 +153,11 @@ gstvideo_dep = dependency('gstreamer-video-1.0', version : gst_req,
gstgl_dep = dependency('gstreamer-gl-1.0', version : gst_req,
fallback : ['gst-plugins-bad', 'gstgl_dep'], required : false)
+if host_machine.system() != 'windows'
+ gstcheck_dep = dependency('gstreamer-check-1.0', version : gst_req,
+ fallback : ['gstreamer', 'gst_check_dep'])
+endif
+
libm = cc.find_library('m', required : false)
glib_dep = dependency('glib-2.0', version : glib_req)
gio_dep = dependency('gio-2.0', version : glib_req)
@@ -305,6 +310,7 @@ subdir('config')
subdir('examples')
subdir('omx')
subdir('tools')
+subdir('tests')
python3 = find_program('python3')
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')