summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2019-09-10 12:55:53 +0530
committerNirbheek Chauhan <nirbheek.chauhan@gmail.com>2019-09-10 08:34:43 +0000
commit87bf1ac9cd7386c918acc4f8335b1548c1cfac11 (patch)
treed6e7dcd541888dc9c3b64c5805b9ffca3f70770c /meson.build
parent8585a5f2b19ed5a4f0aef262243c30d5fe6d61d3 (diff)
meson: libm is not a required library
Most toolchains do not have libm as a separate library at all.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c3e0af8..ea0721e 100644
--- a/meson.build
+++ b/meson.build
@@ -1,7 +1,7 @@
project('gst-examples', 'c', version : '1.17.0.1', license : 'LGPL')
cc = meson.get_compiler('c')
-m_dep = cc.find_library('m', required : true)
+m_dep = cc.find_library('m', required : false)
glib_dep = dependency('glib-2.0', version: '>= 2.38',
fallback: ['glib', 'libglib_dep'])