summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMathieu Duponchelle <mathieu@centricular.com>2018-03-01 18:49:21 +0100
committerMathieu Duponchelle <mathieu@centricular.com>2018-03-01 18:50:22 +0100
commit9a7591397a11a54bd9c33e8cbe1ebf56a9df6941 (patch)
tree39de24ca1cf3daae93f0a8ffe8cc4e7ad9f031c8 /meson.build
parent831a70bf9a99a6a134a648987877f8b594687942 (diff)
meson: enable more warnings
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ed147fb..e74696e 100644
--- a/meson.build
+++ b/meson.build
@@ -108,6 +108,30 @@ if gst_debug_disabled and cc.has_argument('-Wno-unused')
add_project_arguments('-Wno-unused', language: 'c')
endif
+warning_flags = [
+ '-Wmissing-declarations',
+ '-Wmissing-prototypes',
+ '-Wredundant-decls',
+ '-Wundef',
+ '-Wwrite-strings',
+ '-Wformat',
+ '-Wformat-nonliteral',
+ '-Wformat-security',
+ '-Winit-self',
+ '-Wmissing-include-dirs',
+ '-Waddress',
+ '-Wno-multichar',
+ '-Wdeclaration-after-statement',
+ '-Wvla',
+ '-Wpointer-arith',
+]
+
+foreach extra_arg : warning_flags
+ if cc.has_argument (extra_arg)
+ add_project_arguments([extra_arg], language: 'c')
+ endif
+endforeach
+
subdir('validate')
python3 = import('python3').find_python()