summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2019-03-23 19:22:29 +0000
committerTim-Philipp Müller <tim@centricular.com>2019-03-23 19:22:29 +0000
commit2d24674b6c79c349784c5d5a163a6537bc18da51 (patch)
tree4621278c0bdbc6494a18b9763a797aa39ed21984 /meson.build
parentad24cb1b778877a509b31cf7f95ec7e5bf5e20b9 (diff)
g-i: pass --quiet to g-ir-scanner
This suppresses the annoying 'g-ir-scanner: link: cc ..' output that we get even if everything works just fine. We still get g-ir-scanner warnings and compiler warnings if we pass this option.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a8b9817..ae014cb 100644
--- a/meson.build
+++ b/meson.build
@@ -90,7 +90,7 @@ gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' +
'g_setenv("GST_REGISTRY_1.0", "/no/way/this/exists.reg", TRUE);' + \
'g_setenv("GST_PLUGIN_PATH_1_0", "", TRUE);' + \
'g_setenv("GST_PLUGIN_SYSTEM_PATH_1_0", "", TRUE);' + \
- 'gst_init(NULL,NULL);' ]
+ 'gst_init(NULL,NULL);', '--quiet']
gir = find_program('g-ir-scanner', required : get_option('introspection'))
build_gir = gir.found() and not meson.is_cross_build()
gnome = import('gnome')