summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 4 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index ec582e2..c6e6b2a 100644
--- a/meson.build
+++ b/meson.build
@@ -57,13 +57,11 @@ if not meson.is_subproject() and cc.get_id() == 'msvc'
endif
endif
endif
+endif
- # Change some warning which belong to level 3 (production quality) or
- # 4 (informational) to level 1 (severe)
- add_global_arguments (
- '/w14062', # enumerator 'identifier' in switch of enum 'enumeration' is not handled
- '/w14101', # 'identifier' : unreferenced local variable
- '/w14189', # 'identifier' : local variable is initialized but not referenced
+# Ensure that MSVC interprets all source code as UTF-8
+if cc.get_id() == 'msvc'
+ add_global_arguments(
cc.get_supported_arguments(['/utf-8']), # set the input encoding to utf-8
language: ['c', 'cpp'])
endif