summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2010-08-04 19:32:09 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2010-08-04 19:32:09 +0200
commitda587dde493ee7e5f00472f669d4ae0924387956 (patch)
treefba55ff713c1b2bee1b2fa789d5a7668208bc34a /configure.ac
parent211c406b15a941c0cd6de3130321d7d06c7a921e (diff)
configure: Check if the compiler supports ISO C89 or C99 and which parameters are required
This first checks what is required for ISO C99 support and sets the relevant compiler parameters and if no C99 compiler is found, it checks for a C89 compiler. This enables us to check for and use C89/C99 functions that gcc hides from us without the correct compiler parameters.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f8cb409..8d268b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,7 @@ dnl *** checks for programs ***
dnl find a compiler
AC_PROG_CC
+AC_PROG_CC_STDC
dnl check if the compiler supports '-c' and '-o' options
AM_PROG_CC_C_O