summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <ystreet00@gmail.com>2012-11-19 22:50:33 +1100
committerSebastian Dröge <slomo@circular-chaos.org>2013-06-29 10:06:40 +0200
commitacdbcd65a4678431000fb342937077b03270535c (patch)
tree8743657b62e0de7fd8f2e3218cfc57e119ce0d61 /configure.ac
parent28f3208c24f1586a914704fd91c093cec8b85f38 (diff)
fixup GNUstep check for cross compilation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 17 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 5657303..d5dcd7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -252,12 +252,23 @@ case $host in
esac
case $host in
- *-darwin* )
- ;;
+ *-darwin* ) ;;
*)
AC_PATH_PROG([GNUSTEP_CONFIG],[gnustep-config])
if test "x$GNUSTEP_CONFIG" != "x"; then
- HAVE_GNUSTEP_COCOA=yes
+ GNUSTEP_HOST="`$GNUSTEP_CONFIG --variable=GNUSTEP_HOST`"
+ case $host in
+ *-mingw* )
+ case $GNUSTEP_HOST in
+ *-mingw* )
+ HAVE_GNUSTEP_COCOA=yes
+ ;;
+ esac
+ ;;
+ * )
+ HAVE_GNUSTEP_COCOA=yes
+ ;;
+ esac
fi
;;
esac
@@ -367,10 +378,6 @@ case $host in
if test "x$NEED_GL" != "xno"; then
GL_LIBS="$GL_LIBS -lGL -lGLU -lGLEW"
fi
- else dnl no Desktop OpenGL
- if test "x$NEED_GLX" = "xyes"; then
- AC_MSG_ERROR([Building the GLX backend without the OpenGL backend is unsupported])
- fi
fi
dnl OpenGL|ES 2.0
@@ -384,9 +391,6 @@ case $host in
dnl EGL
if test "x$HAVE_EGL" = "xno"; then
- if test "x$NEED_EGL" = "xyes"; then
- AC_MSG_ERROR([Could not find the required EGL libraries])
- fi
if test "x$HAVE_GL" = "xno"; then
AC_MSG_ERROR([Building requires either EGL or GLX])
fi
@@ -397,16 +401,16 @@ case $host in
USE_EGL=yes
fi
fi
-
+
HAVE_WINDOW_X11=yes
AC_DEFINE(HAVE_WINDOW_X11, [1], [Have X11 window libraries])
dnl GNUstep provides the Cocoa API on unix
if test "x$HAVE_GNUSTEP_COCOA" = "xyes" ; then
- GNUSTEP_CFLAGS="`$GNUSTEP_CONFIG --objc-flags`"
+ GNUSTEP_OBJCFLAGS="`$GNUSTEP_CONFIG --objc-flags`"
GNUSTEP_LIBS="`$GNUSTEP_CONFIG --gui-libs`"
GL_LIBS="$GL_LIBS $GNUSTEP_LIBS -lgnustep-gui -lgnustep-base"
- OBJCFLAGS="$OBJCFLAGS $GNUSTEP_CFLAGS"
+ OBJCFLAGS="$OBJCFLAGS $GNUSTEP_OBJCFLAGS"
AC_DEFINE(HAVE_COCOA, [1], [Have Cocoa OpenGL libraries])
AC_DEFINE(HAVE_WINDOW_COCOA, [1], [Have Cocoa window libraries])