summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <ystreet00@gmail.com>2012-11-15 13:17:59 +1100
committerSebastian Dröge <slomo@circular-chaos.org>2013-06-29 10:06:39 +0200
commit340802d6b90882b479b36098258fc61bc1351a3b (patch)
treecf79a3d6e0404730c1b4b97d553bfc89b545a43a /configure.ac
parent9cc15243d7ae099f25f7419df1ffd34efb9ed056 (diff)
win32 port of determining GL platform at runtime
- add GstGLWindowWin32 and GstGLWindowWin32WGL along the same lines as the X11 variants
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ea5b384..31c0b3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -330,12 +330,14 @@ case $host in
GL_LIBS="$LIBS -framework OpenGL -framework Cocoa"
CPPFLAGS="$CPPFLAGS -framework OpenGL"
HAVE_WINDOW_COCOA=yes
+ AC_DEFINE(HAVE_WINDOW_COCOA, [], [Have Cocoa window libraries])
USE_GL=yes
USE_CGL=yes
;;
*-mingw32*)
GL_LIBS="$LIBS -lgdi32 -lopengl32 -lglu32 -lglew32"
HAVE_WINDOW_WIN32=yes
+ AC_DEFINE(HAVE_WINDOW_WIN32, [], [Have Win32 window libraries])
USE_GL=yes
USE_WGL=yes
;;