summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Isorce <julien.isorce@collabora.co.uk>2013-10-01 12:07:36 +0100
committerJulien Isorce <julien.isorce@collabora.co.uk>2013-10-01 12:52:28 +0100
commit2580ae8bf4bf61749e37d4538cfd99ec7dbeca3a (patch)
treec5584403e9fbd645e556a3235496dd68fd28f3c1 /configure.ac
parent7c748bfb8096ad67b9ed2eb85afcfe662727cf51 (diff)
configure.ac: make generic HAVE_EGL case add -lEGL on rpi
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 94fbfdb..0214b25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -318,7 +318,7 @@ case $host in
HAVE_EGL=yes
HAVE_GLES2=yes
HAVE_EGL_RPI=yes
- EGL_LIBS="-lEGL -lbcm_host -lvcos -lvchiq_arm"
+ EGL_LIBS="-lbcm_host -lvcos -lvchiq_arm"
EGL_CFLAGS=""
AC_DEFINE(USE_EGL_RPI, [1], [Use RPi platform])
])
@@ -548,7 +548,7 @@ case $host in
fi
else
if test "x$NEED_EGL" != "xno"; then
- if test "x$HAVE_WINDOW_WAYLAND" = "xyes" -o "x$HAVE_WINDOW_X11" = "xyes"; then
+ if test "x$HAVE_WINDOW_WAYLAND" = "xyes" -o "x$HAVE_WINDOW_X11" = "xyes" -o "x$HAVE_WINDOW_DISPMANX" = "xyes"; then
GL_LIBS="$GL_LIBS -lEGL"
USE_EGL=yes
fi