summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2008-01-17 19:40:36 +0000
committerDavid Schleef <ds@schleef.org>2008-01-17 19:40:36 +0000
commitb39b831c22feda65c639842a551d4e45efb4906f (patch)
tree6b9dcac3a8efdcf87c1515a54e4b75ad808197f7 /Makefile.am
parent2953999957a7ffca99416d78d5749602ef4a8218 (diff)
Add project infrastructure. Not complete, doesn't work.
* .cvsignore: * AUTHORS: * COPYING: * COPYING.LIB: * INSTALL: * Makefile.am: * NEWS: * README: * RELEASE: * REQUIREMENTS: * autogen.sh: * configure.ac: * docs/.cvsignore: * docs/Makefile.am: * docs/libs/Makefile.am: * docs/plugins/Makefile.am: * docs/version.entities.in: * ext/Makefile.am: * gst-libs/Makefile.am: * gst-libs/gst/Makefile.am: * gst-libs/gst/gl/Makefile.am: * gst-plugins-gl.doap: * gst-plugins-gl.spec.in: * gst/Makefile.am: * m4/.cvsignore: * m4/Makefile.am: * pkgconfig/.cvsignore: * pkgconfig/Makefile.am: * pkgconfig/gstreamer-plugins-gl-uninstalled.pc.in: * pkgconfig/gstreamer-plugins-gl.pc.in: * sys/Makefile.am: * tests/Makefile.am: * tests/check/Makefile.am: * tests/examples/Makefile.am: * tests/icles/Makefile.am: * tools/Makefile.am: * win32/common/config.h.in:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am68
1 files changed, 68 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..6d31913
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,68 @@
+DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+
+if BUILD_EXTERNAL
+SUBDIRS_EXT = ext
+else
+SUBDIRS_EXT =
+endif
+
+SUBDIRS = \
+ gst-libs \
+ gst sys $(SUBDIRS_EXT) \
+ tools \
+ tests \
+ docs \
+ po \
+ common \
+ m4 \
+ pkgconfig
+
+DIST_SUBDIRS = \
+ docs \
+ gst-libs \
+ gst sys ext \
+ tools \
+ tests \
+ po \
+ common \
+ m4 \
+ pkgconfig
+
+# include before EXTRA_DIST for win32 assignment
+include $(top_srcdir)/common/win32.mak
+
+EXTRA_DIST = \
+ gst-plugins-gl.spec depcomp \
+ AUTHORS COPYING COPYING.LIB NEWS README RELEASE REQUIREMENTS \
+ ChangeLog gst-plugins-gl.doap autogen.sh $(win32)
+
+DISTCLEANFILES = _stdint.h
+
+ACLOCAL_AMFLAGS = -I m4 -I common/m4
+
+include $(top_srcdir)/common/release.mak
+include $(top_srcdir)/common/po.mak
+
+check-valgrind:
+ cd tests/check && make check-valgrind
+
+if HAVE_GST_CHECK
+check-torture:
+ cd tests/check && make torture
+else
+check-torture:
+ true
+endif
+
+WIN32_COPY = \
+ $(top_builddir)/gst-libs/gst/*/*-enumtypes.[ch] \
+ $(top_builddir)/_stdint.h
+
+win32-update:
+ for f in $(WIN32_COPY); do cp $$f win32/common;done
+
+include $(top_srcdir)/common/coverage/lcov.mak
+
+check: check-exports
+
+