summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@gnome.org>2016-04-06 10:46:51 +0200
committerThibault Saunier <tsaunier@gnome.org>2016-04-06 12:18:18 +0200
commit629b3d800b2ab634180e4ca69f3dbdb9105716c8 (patch)
tree7891b01be0cab26f1c4e2fe5569e1b4a2da9c118 /setup.py
parent4077ec07b2d7dc0b28c6ffde3c7dc5d897c77e83 (diff)
Add a setup.py file so user can install with pip1.0.01.0
And fix the README markdown so it can be used by setuptools Differential Revision: https://phabricator.freedesktop.org/D891
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..6616010
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+import os
+
+from setuptools import setup
+
+
+setup(
+ name="git-phab",
+ version="1.0",
+ author="Xavier Claessens",
+ author_email="xavier.claessens@collabora.com",
+ description=("Git subcommand to integrate with phabricator"),
+ license="GPL",
+ keywords="phabricator tool git",
+ url="http://packages.python.org/git-phab",
+ long_description_markdown_filename='README.md',
+ setup_requires=['setuptools-markdown'],
+ classifiers=[
+ "Topic :: Utilities",
+ "License :: OSI Approved :: GNU General Public License (GPL)"
+ ],
+ install_requires=['GitPython', 'appdirs', 'argcomplete'],
+ scripts=['git-phab'],
+)