summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2012-08-27 14:34:18 -0400
committerBehdad Esfahbod <behdad@behdad.org>2012-08-27 14:34:18 -0400
commit9a4a7d805e4055839b319c7b5b6382a7101b1980 (patch)
treea7910a181d765d6f87a661aaf4ccbcd257dc19b2 /Makefile.am
parent6b0423949010d4aa596099bba62992b8c28b5abf (diff)
Minor
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 31e3747..35d7721 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,4 +70,27 @@ ChangeLog:
fi
.PHONY: $(srcdir)/ChangeLog
+#
+# Release engineering
+#
+
+TAR_OPTIONS = --owner=0 --group=0
+dist-hook: dist-clear-sticky-bits
+# Clean up any sticky bits we may inherit from parent dir
+dist-clear-sticky-bits:
+ chmod -R a-s $(distdir)
+
+
+tar_file = $(PACKAGE_TARNAME)-$(VERSION).tar.bz2
+sha256_file = $(tar_file).sha256
+gpg_file = $(sha256_file).asc
+$(sha256_file): $(tar_file)
+ sha256sum $^ > $@
+$(gpg_file): $(sha256_file)
+ @echo "Please enter your GPG password to sign the checksum."
+ gpg --armor --sign $^
+
+release-files: $(tar_file) $(sha256_file) $(gpg_file)
+
+
-include $(top_srcdir)/git.mk