summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2009-06-24 14:43:32 -0400
committerBehdad Esfahbod <behdad@behdad.org>2009-06-24 14:43:43 -0400
commitd07059b7a3f8044904d884818d5e03596e7cc1a2 (patch)
tree66862ac14814c3a38cade9bad80f2424c4f1970f /Makefile.am
parentb65fa0c3113bd1e1cec38d05f8c4f45f78e3e044 (diff)
Fix distcheck
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 2d1de2b..e08857e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,11 +63,10 @@ endif
# Creating ChangeLog from git log:
-MAINTAINERCLEANFILES += ChangeLog
-
+MAINTAINERCLEANFILES += $(srcdir)/ChangeLog
EXTRA_DIST += ChangeLog
-
-ChangeLog:
+ChangeLog: $(srcdir)/ChangeLog
+$(srcdir)/ChangeLog:
if test -d "$(srcdir)/.git"; then \
(GIT_DIR=$(top_srcdir)/.git ./missing --run git log --stat) | fmt --split-only > $@.tmp \
&& mv -f $@.tmp $@ \